今天在修改博客主题时使用到了npm,在安装依赖时,报错:ReferenceError: primordials is not defined,瞬间懵圈,没有百度解决不了的问题,如果解决不了,那就Google。

百度一查,原来是node版本的问题

卸载现在的再下载新的安装,这不是脱裤子放屁——多此一举嘛,网上永不缺大神。

一个大神开发了一个node版本管理器叫做nvm

果断下载试一试,果然解决了😄

解决办法

  1. 卸载本机已安装的nodejs
  2. 安装nvm
  1. 安装完成后,使用下面命令管理自己的nodejs即可
1
2
3
4
5
6
7
8
9
10
11
# 查看本地安装的所有版本;有可选参数available,显示所有可下载的版本。
nvm list [available]

# 安装,命令中的版本号可自定义,具体参考命令1查询出来的列表
nvm install 11.13.0

# 使用特定版本
nvm use 11.13.0

# 卸载
nvm uninstall 11.13.0